package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?[1-9]?\d(?:\.\d)?$`)
var str = `1
1.1
01.1
01
11
11.1
0
0.1
00.1
11.1
1.
-9
-0.9
-100
100
-99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}