import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?[1-9]?\\d(?:\\.\\d)?$";
final String string = "1\n"
+ "1.1\n"
+ "01.1\n"
+ "01\n"
+ "11\n"
+ "11.1\n"
+ "0\n"
+ "0.1\n"
+ "00.1\n"
+ "11.1\n"
+ "1.\n"
+ "-9\n"
+ "-0.9\n"
+ "-100\n"
+ "100\n"
+ "-99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}