using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,2}-\d{1,2}-\d{4}";
string substitution = @"";
string input = @"1-23-2018";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}