use strict;
my $str = '1-23-2018';
my $regex = qr/\d{1,2}-\d{1,2}-\d{4}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";