package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W`)
var str = `@BindView(R.id.tab_layout) TabLayout tabLayout;`
var substitution = "var ${name}: ${type} = findViewById(${id})"
fmt.Println(re.ReplaceAllString(str, substitution))
}