use strict;
my $str = '@BindView(R.id.tab_layout) TabLayout tabLayout;';
my $regex = qr/@BindView\((?<id>.*?)\)\W+(?<type>.*?)\W+(?<name>.*?)\W/mp;
my $subst = 'var ${name}: ${type} = findViewById(${id})';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";