$re = '/.*Räume(?:\.\w*){1,2}$/m';
$str = '0_userdata.0.Räume.Wohnzimmer
0_userdata.0.Räume.Wohnzimmer.H2
0_userdata.0.Räume.control.Test.Test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);