#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0(\.[0-9]+)?$|^[1-9][0-9]*(\.[0-9]+)?$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"01" & @CRLF & _
"01.1" & @CRLF & _
"1.1" & @CRLF & _
"11.1234" & @CRLF & _
"5123" & @CRLF & _
"1351523.123" & @CRLF & _
"0.1234" & @CRLF & _
"0.0" & @CRLF & _
"0.000" & @CRLF & _
"0.00001" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")