package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0(\.[0-9]+)?$|^[1-9][0-9]*(\.[0-9]+)?$`)
var str = `0
1
01
01.1
1.1
11.1234
5123
1351523.123
0.1234
0.0
0.000
0.00001
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}