#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:(?:0*(\d+)d\s)?0*(\d+)h\s)?0*(\d+)m\s)?0*(\d+)s"
Local $sString = "98d 01h 23m 45s" & @CRLF & _
"01d 02h 03m 04s" & @CRLF & _
"02h 03m 04s" & @CRLF & _
"03m 04s" & @CRLF & _
"04s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")