package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:(?:0*(\d+)d\s)?0*(\d+)h\s)?0*(\d+)m\s)?0*(\d+)s`)
var str = `98d 01h 23m 45s
01d 02h 03m 04s
02h 03m 04s
03m 04s
04s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}