import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+{0,})(\\d{0,})([(]{1}\\d{1,3}[)]{0,}){0,}(\\s?\\d+|\\+\\d{2,3}\\s{1}\\d+|\\d+){1}[\\s|-]?\\d+([\\s|-]?\\d+){1,2}(\\s){0,}$";
final String string = "(123) 456-7890\n"
+ "(123)456-7890\n"
+ "123-456-7890\n"
+ "1234567890\n"
+ "+31636363634\n"
+ "+3(123) 123-12-12\n"
+ "+3(123)123-12-12\n"
+ "+3(123)1231212\n"
+ "+3(123) 12312123\n"
+ "+3(123) 123 12 12\n"
+ "075-63546725\n"
+ "+7910 120 54 54 \n"
+ "910 120 54 54 \n"
+ "8 999 999 99 99 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}