$re = '/^(\+{0,})(\d{0,})([(]{1}\d{1,3}[)]{0,}){0,}(\s?\d+|\+\d{2,3}\s{1}\d+|\d+){1}[\s|-]?\d+([\s|-]?\d+){1,2}(\s){0,}$/m';
$str = '(123) 456-7890
(123)456-7890
123-456-7890
1234567890
+31636363634
+3(123) 123-12-12
+3(123)123-12-12
+3(123)1231212
+3(123) 12312123
+3(123) 123 12 12
075-63546725
+7910 120 54 54
910 120 54 54
8 999 999 99 99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);