package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\u(\w{4})`)
var str = `^(?:[A-Za-z0-9\u00C0-\u017F\u20AC\u2122\u2150\u00A9 \/.,\-_$!\'&*()="?#+%:;\<\[\]\r\r\n]|(?:\ud83c[\udf00-\udfff])|(?:\ud83d[\udc00-\ude4f\ude80-\udeff]))*$`
var substitution = "\\x{$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}