#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\d.[0-9:,]+\s-->\s[\d+:,]+."
Local $sString = "5" & @CRLF & _
"00:05:50,141 --> 00:05:54,771" & @CRLF & _
"This is what was said"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)