// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\d.[0-9:,]+\s-->\s[\d+:,]+.").unwrap();
let string = "5
00:05:50,141 --> 00:05:54,771
This is what was said";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}