using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?\d+$";
string input = @"-1234
543
51.23
-512.345612
-5.1-2
-5.-2
5.1.2
51foo51
foo1
1foo
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}