$re = '/(?<!_)_{1,2}(?=_[^_])|(?<=\.jav)a$/m';
$str = 'remote_execute___jenkin%.java
remtoe__plat_jenk.java
remtoe_plat_jenk.java
remtoe___plat_jenk.testa
remote_execute____jenkin%.java';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;