#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<!&)(?:\b(?:nbsp|quot|divide)|#[0-9a-f]+);"
Local $sString = "I have a huge HTML with several special chars, in the forms or "�." & @CRLF & _
"Faulty HEX: #82173333;" & @CRLF & _
"Some of them are wrong, because they lack the initial &." & @CRLF & _
"" & @CRLF & _
"I would like to search for such wrong spacial chars. I know that I can search all the right special chars by means of the following regex:" & @CRLF & _
"" & @CRLF & _
" \&(?:[a-z]+|#x?\d+);\" & @CRLF & _
"But I'd need a regex useful to search the wrong ones (without the initial &). Can you help me? Thanks in advance" & @CRLF & _
"" & @CRLF & _
"Edit:" & @CRLF & _
"" & @CRLF & _
"As suggested, I post an example. My HTML cointains the following statement:" & @CRLF & _
"" & @CRLF & _
" <![CDATA[<nolink>blablabla blablabla</nolink>]]>nbsp;" & @CRLF & _
"where we have 2 special HTML character:" & @CRLF & _
"divide;" & @CRLF & _
"÷" & @CRLF & _
" " & @CRLF & _
"quot;" & @CRLF & _
"I'm interested in finding the second item, because it is wrong (laking the initial &)." & @CRLF & _
"" & @CRLF & _
"So the output of the requested regex should be: quot;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")