$re = '/\b(\p{Lu}[\p{Lu}+\p{Ll}]*\p{Lu}*)|(\p{Lu}*[\p{Lu}+\p{Ll}]*\p{Lu}+)\b/m';
$str = 'hello world at MSDN Magazie published in LaTeX Format tomaX Tomax TMa TMAx TmAX toTHE ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);