using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bkey=""(abcd(?=.*-xyz\b)(?:-[a-z]+){4})""";
string input = @"object{one=""ab-vwxc"",two=""value1"",key=""abcd-eest-wd-xyz-bnn"",four=""obsolete Values""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}