re = /\bkey="(abcd(?=.*-xyz\b)(?:-[a-z]+){4})"/m
str = 'object{one="ab-vwxc",two="value1",key="abcd-eest-wd-xyz-bnn",four="obsolete Values"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end