$re = '/^[a-z0-9]*[a-z]+[a-z0-9]*$/m';
$str = '8
123
1a2b3c
a1b2c3
abc123
123abc
abc
abc!
!abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);