re = /^([\da-zA-Z]{2})([\da-zA-Z]{2})(?=([\da-zA-Z]{6})).([\da-zA-Z].*)$/m
str = 'abcdefghijghij12345
'
subst = '1st: \\1\\n2nd: \\2\\n3rd: \\3\\n4th: \\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result