use strict;
my $str = 'I [06/Jul/2020:21:30:35 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:36 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:37 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
tr tr
tr tr
tr
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
tr
tr
tr';
my $regex = qr/^(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])(.*)(\r?\n(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])\3)+$/mp;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";