import Foundation
let pattern = #"^(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])(.*)(\r?\n(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])\3)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I [06/Jul/2020:21:30:35 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:36 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:37 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
tr tr
tr tr
tr
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
tr
tr
tr
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)