const regex = new RegExp('[^\\d\\r\\n]+(\\d{1,2}-\\d{1,2})|.+', 'gm')
const str = `'dkas;6-17
'dsajdl 10'
'dsjalkdj16-20'`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);