use strict;
my $str = '\'dkas;6-17
\'dsajdl 10\'
\'dsjalkdj16-20\'';
my $regex = qr/[^\d\r\n]+(\d{1,2}-\d{1,2})|.+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";