const regex = /^[A-Za-z0-9\ ,]+\.1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9\\ ,]+\\.1', 'gm')
const str = `1082805252197942751,34225793738713276,serialtooldata,1,Goals,75512140,125.0,63.0,29.0,1,,,,0,899,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}