$re = '/(\.|^)(?=(\w*\.\w*))/m';
$str = 'test1.test2.abc.def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);