$re = '/\n(?!\d+,)/m';
$str = 'id, text field1, text field2
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text
1a,wewe
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;