#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^98]"
Local $sString = "989127256533" & @CRLF & _
"9820207" & @CRLF & _
"20157" & @CRLF & _
"982188665998" & @CRLF & _
"4476587" & @CRLF & _
"989121465468" & @CRLF & _
"989194587989" & @CRLF & _
"98110" & @CRLF & _
"98119" & @CRLF & _
"989335465987" & @CRLF & _
"989206546545" & @CRLF & _
"989216548787"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")