package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^98]`)
var str = `989127256533
9820207
20157
982188665998
4476587
989121465468
989194587989
98110
98119
989335465987
989206546545
989216548787`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}