import Foundation
let pattern = #"^(?:<[pP]>)?(?:<strong>)?(?:<[aA]\s\w+="[\-\/\wÅåÄäÖö;,.\(\)\[\]&\s]+">(?:<\/[aA]>)?)?[\-\/\wÅåÄäÖö;,.\(\)\[\]&\s]+(?:<\/strong>)?[\-\/\wÅåÄäÖö;,.\(\)\[\]&\s]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<strong><A NAME="Bondeupproret"></A>Andersson, Per,</strong> Bondeupproret i Skåne 1811 / Per Andersson, Arne Ribnell. – [Ny, utökad uppl.]. – Malmö, 1996. – 12 s.
<p><strong><br />Andersson, Per,</strong> Litteratur om Svedalatrakten. – Malmö[?], 197-. – 6 bl.
<p><strong><br /><A NAME="borgar_slott"></A>Andersson, Per,</strong> Skånska borgar, slott och herrgårdar. – Lund, 1996. – 212 s.
<p><strong><br /><A NAME="Skånska_kyrkor"></A>Andersson, Per,</strong> Skånska kyrkor, kapell, kloster och andra kyrkliga byggnader. – Malmö, 1985. – 254 s.
<p><strong><br /><A NAME="Att_läsa"></A>Ericsson, Acke,</strong> Att läsa om Sturup. // SkNK. – 1973, h. 1, s. 37-40.
<br />Urval ur Acke Ericssons bibliografi, se nedan.
<p><strong><br /><A NAME="Sturup"></A>Ericsson, Acke,</strong> Sturup. – Malmö, 1973. – 24 bl.
<p><strong><br />Jönsson, Knut,</strong> Anteckningar till en bibliografi över Bara kommun. – Borås, 1975. – 76 bl.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)