const regex = /\bCOLOR="[^\na-zA-Z"]*\b([a-zA-Z]+)\b[^\n"]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bCOLOR="[^\\na-zA-Z"]*\\b([a-zA-Z]+)\\b[^\\n"]*"', 'gm')
const str = `COLOR="WHITE 화이트", DETAIL="NONE"
SLEEVE="SHORT 쇼트", COLOR="BLUE"
SLEEVE="LONG", COLOR="GRAY", TOP="DOUBLE"
COLOR="YELLOW 노랑"
COLOR="화이트 WHITE", DETAIL="NONE"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}