re = /ExceptionName:\s+(?<message>[^\.\<]+)/m
str = 'stack_trace : com.abc.xyz.package.ExceptionName: Missing A.
stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end