Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[a-z]+(?:_[a-z]+)*$
/
gm
Test String
New
welcome_to_snake_case PASS : snake_case cellule sous_cellule a a_a all_good FAIL : /^[a-z]+(\_[a-z]+)*$/gm camelCase PascalCase kebab-case UPPERCASE big_sNAKe_case snake_digita1ised_case one_is_there^ _ ___ no_trailing_dash_ _actually_neither_way _norboth_ no_space no_other_special-char all_good?yes