#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ \t]*((none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset){1}([ \t]+(none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset)){0,3})[\t ]*$"
Local $sString = " " & @CRLF & _
" none" & @CRLF & _
"dotted " & @CRLF & _
" dashed " & @CRLF & _
" dotted dotted " & @CRLF & _
"dashed dashed dashed" & @CRLF & _
" solid solid solid solid" & @CRLF & _
" inset outset" & @CRLF & _
"" & @CRLF & _
"# Errors - must not match" & @CRLF & _
"nonee" & @CRLF & _
"dotte2d" & @CRLF & _
"dashed-" & @CRLF & _
"dotted -dotted" & @CRLF & _
"dasheddashed dashed" & @CRLF & _
"solid fake solid solid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")