using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*((none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset){1}([ \t]+(none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset)){0,3})[\t ]*$";
string input = @"
none
dotted
dashed
dotted dotted
dashed dashed dashed
solid solid solid solid
inset outset
# Errors - must not match
nonee
dotte2d
dashed-
dotted -dotted
dasheddashed dashed
solid fake solid solid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}