import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*((none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset){1}([ \\t]+(none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset)){0,3})[\\t ]*$";
final String string = " \n"
+ " none\n"
+ "dotted \n"
+ " dashed \n"
+ " dotted dotted \n"
+ "dashed dashed dashed\n"
+ " solid solid solid solid\n"
+ " inset outset\n\n"
+ "# Errors - must not match\n"
+ "nonee\n"
+ "dotte2d\n"
+ "dashed-\n"
+ "dotted -dotted\n"
+ "dasheddashed dashed\n"
+ "solid fake solid solid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}