using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(['""])(?>\\\1|(?!\1)[\w\W])*\1|\/\*[\w\W]*?\*\/)(*SKIP)(*F)|\h*\/\/.*+";
string substitution = @"";
string input = @"""Testing a comment here // comment"" // comment
// comment
""A bit \"" trickier yet \"" // comment"" // comment
// comment
// ""This should match since the comment came first""
'Single \' quotes // comment' // comment
'''
Ignore
// comment
\''''
// comment
/*
multiline
// comment
*/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}