import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https)\\:\\/\\/[a-zA-Z0-9\\-\\.]+(\\.[a-zA-Z]{2,3})?(\\/[A-Za-z0-9-._~!$&()*+,;=:]*)*";
final String string = "http://www.something.com and https://www.something.com</p> are working. Also http://www.something.com/some/thing/index.html works. \n\n"
+ "www.something.com not and http://something.com. also gives a problem. Also https://something.com/something/else/test?something=true. \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}