package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2}\/\d{2}\/\d{2})\s(\d{2}\:\d{2})\s(\d+)\s(Allow|Reject)\s(.*)(\d+)\s(tcp|udp)\s(.*)\s(.*)\s(\d+)`)
var str = `09/21/11 10:47 29 Allow Partner-SQL-eComm 46990 tcp Partner-Web-eComm mysql 19999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}