import re
regex = re.compile(r"([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)")
test_str = "Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140"
subst = "$1: $2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)