import Foundation
let pattern = #"([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)