// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http[^\s]+(jpg|jpeg|png|webp)\b)").unwrap();
let string = " <picture>
<source type=\"image/webp\" data-srcset=\"https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp\" srcset=\"https://assets.watchbase.com/img/FFFFFF-0.png\" />
<img class=\"lazyload\" data-src=\"https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png\" src=\"https://assets.watchbase.com/img/FFFFFF-0.png\" alt=\"Sellita caliber SW510 BH b\"/>
</picture>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}