package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)font[^;"]+;?`)
var str = `В админке есть несколько текстовых полей, обрабатываемых в контроллере. На выходе — разметка, представленная строкой. Необходимо с помощью регулярки удалить из неё все свойства из атрибутов style, начинающиеся с заданной явно подстроки. Например, при заданном "font-" нужно удалить конструкции вида "font-size: 16px;", "font-weight: 400;" и т.д. Атрибут style в строке может style="font-blahblah"встречаться неоднократно.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}