re = /(.)\1+(?!\1)(.)\2+/
str = 'wuzDDDFFFxji
qwuiuQQQQQsas
qwuiuQQQQQssssas
qwuiuQQQQQsas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end