#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "R(\[-?[1-9][0-9]*\])C(\[-?[1-9][0-9]*\])|R(\[-?[1-9][0-9]*\])C|RC(\[-?[1-9][0-9]*\])"
Local $sString = "RC" & @CRLF & _
"RC[1]" & @CRLF & _
"RC[-1]" & @CRLF & _
"R[1]C" & @CRLF & _
"R[-1]C" & @CRLF & _
"R[1]C[1]" & @CRLF & _
"R[-1]C[1]" & @CRLF & _
"R[1]C[-1]" & @CRLF & _
"R[-1]C[-1]" & @CRLF & _
"R[0]C[1]" & @CRLF & _
"RC[0]" & @CRLF & _
"R[1]C[0]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")