package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`R(\[-?[1-9][0-9]*\])C(\[-?[1-9][0-9]*\])|R(\[-?[1-9][0-9]*\])C|RC(\[-?[1-9][0-9]*\])`)
var str = `RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[0]C[1]
RC[0]
R[1]C[0]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}